using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"s[4-9]\d*";
string input = @"s000000000 s1133122 s21 s3 s4 s5212638476234857634 s6 s7 s8 s9000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}