// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)s[4-9]\d*").unwrap();
let string = "s000000000 s1133122 s21 s3 s4 s5212638476234857634 s6 s7 s8 s9000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}