package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)s[4-9]\d*`)
var str = `s000000000 s1133122 s21 s3 s4 s5212638476234857634 s6 s7 s8 s9000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}