re = /s[4-9]\d*/m
str = 's000000000 s1133122 s21 s3 s4 s5212638476234857634 s6 s7 s8 s9000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end