$re = '/s[4-9]\d*/m';
$str = 's000000000 s1133122 s21 s3 s4 s5212638476234857634 s6 s7 s8 s9000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);