using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@osh\.co\.za>";
string input = @"From: Paul Ogier <paul@osh.co.za>
From: Paul van der Merwe <paul@osh.co.za>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}