package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@osh\.co\.za>`)
var str = `From: Paul Ogier <paul@osh.co.za>
From: Paul van der Merwe <paul@osh.co.za>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}