const regex = /^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@osh\.co\.za>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^From:\\s[A-Za-z]+\\s[A-Za-z]+(\\s[A-Za-z]+)?(\\s[A-Za-z]+)?\\s<[A-Za-z]+@osh\\.co\\.za>', 'gm')
const str = `From: Paul Ogier <paul@osh.co.za>
From: Paul van der Merwe <paul@osh.co.za>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}