re = /^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@osh\.co\.za>/m
str = 'From: Paul Ogier <paul@osh.co.za>
From: Paul van der Merwe <paul@osh.co.za>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end