$re = '/^From:\s[A-Za-z]+\s[A-Za-z]+(\s[A-Za-z]+)?(\s[A-Za-z]+)?\s<[A-Za-z]+@osh\.co\.za>/m';
$str = 'From: Paul Ogier <paul@osh.co.za>
From: Paul van der Merwe <paul@osh.co.za>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);