using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\_t";
string substitution = @"$1";
string input = @"http://www.example.com/this-is-a-tag_t
http://www.example.com/other-is-a-tag_t
https://example.com/wp-login.php?reauth=1&redirect_to=https://example.com/wp-admin/
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}