re = /(.*)\_t/m
str = 'http://www.example.com/this-is-a-tag_t
http://www.example.com/other-is-a-tag_t
https://example.com/wp-login.php?reauth=1&redirect_to=https://example.com/wp-admin/
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result