$re = '/(.*)\_t/m';
$str = 'http://www.example.com/this-is-a-tag_t
http://www.example.com/other-is-a-tag_t
https://example.com/wp-login.php?reauth=1&redirect_to=https://example.com/wp-admin/
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;