import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)\\_t";
final String string = "http://www.example.com/this-is-a-tag_t\n"
+ "http://www.example.com/other-is-a-tag_t\n"
+ "https://example.com/wp-login.php?reauth=1&redirect_to=https://example.com/wp-admin/\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}