#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\((?=[^,)]*,)(?:(?:USA|\w+),?\s*)+\)"
Local $sString = "Match Me! (USA, Europe)" & @CRLF & _
"Match Me! (Europe, USA)" & @CRLF & _
"Match Me! (Asia, USA, Europe)" & @CRLF & _
"" & @CRLF & _
"Don't Match Me (USA)" & @CRLF & _
"Don't Match Me ,USA" & @CRLF & _
"USA, Don't Match Me" & @CRLF & _
" USA Don't Match Me" & @CRLF & _
"Don't Match Me (USA)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")