re = /\((?=[^,)]*,)(?:(?:USA|\w+),?\s*)+\)/
str = 'Match Me! (USA, Europe)
Match Me! (Europe, USA)
Match Me! (Asia, USA, Europe)
Don\'t Match Me (USA)
Don\'t Match Me ,USA
USA, Don\'t Match Me
USA Don\'t Match Me
Don\'t Match Me (USA)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end