import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?=[^,)]*,)(?:(?:USA|\\w+),?\\s*)+\\)";
final String string = "Match Me! (USA, Europe)\n"
+ "Match Me! (Europe, USA)\n"
+ "Match Me! (Asia, USA, Europe)\n\n"
+ "Don't Match Me (USA)\n"
+ "Don't Match Me ,USA\n"
+ "USA, Don't Match Me\n"
+ " USA Don't Match Me\n"
+ "Don't Match Me (USA)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}