import re
regex = re.compile(r"\((?=[^,)]*,)(?:(?:USA|\w+),?\s*)+\)")
test_str = ("Match Me! (USA, Europe)\n"
"Match Me! (Europe, USA)\n"
"Match Me! (Asia, USA, Europe)\n\n"
"Don't Match Me (USA)\n"
"Don't Match Me ,USA\n"
"USA, Don't Match Me\n"
" USA Don't Match Me\n"
"Don't Match Me (USA)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")