$re = '/\((?=[^,)]*,)(?:(?:USA|\w+),?\s*)+\)/';
$str = 'Match Me! (USA, Europe)
Match Me! (Europe, USA)
Match Me! (Asia, USA, Europe)
Don\'t Match Me (USA)
Don\'t Match Me ,USA
USA, Don\'t Match Me
USA Don\'t Match Me
Don\'t Match Me (USA)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);