#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]"
Local $sString = "2020-11-09_15:36:38" & @CRLF & _
"2020-12-29_15:36:38" & @CRLF & _
"2029-09-09_15:36:38" & @CRLF & _
"2020-11-31_15:36:38" & @CRLF & _
"2020-11-31_00:00:00" & @CRLF & _
"2020-11-31_23:59:59" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")