package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]`)
var str = `2020-11-09_15:36:38
2020-12-29_15:36:38
2029-09-09_15:36:38
2020-11-31_15:36:38
2020-11-31_00:00:00
2020-11-31_23:59:59
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}