import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]";
final String string = "2020-11-09_15:36:38\n"
+ "2020-12-29_15:36:38\n"
+ "2029-09-09_15:36:38\n"
+ "2020-11-31_15:36:38\n"
+ "2020-11-31_00:00:00\n"
+ "2020-11-31_23:59:59\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}