# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]"
test_str = ("2020-11-09_15:36:38\n"
"2020-12-29_15:36:38\n"
"2029-09-09_15:36:38\n"
"2020-11-31_15:36:38\n"
"2020-11-31_00:00:00\n"
"2020-11-31_23:59:59\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.