using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"202[0-9]-(1[0-2]|0[1-9])-(0[1-9]|[1-2][0-9]|3[0-1])_([0-1][0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]";
string input = @"2020-11-09_15:36:38
2020-12-29_15:36:38
2029-09-09_15:36:38
2020-11-31_15:36:38
2020-11-31_00:00:00
2020-11-31_23:59:59
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}