import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<param name=[^<]+?<\\/param>";
final String string = "fasfasd fsdaf asdf sdaf asd<param name=\"Текст\">текст</param> f asdfsadf sad fasd\n"
+ "sd fasdf sdaf asd<param name=\"Картинки\">https://domen.ru</param> dsfasd fsdaf asd\n"
+ "<param name=\"Числа\">9999</param> sdf as sdf asd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}