re = /<param name=[^<]+?<\/param>/m
str = 'fasfasd fsdaf asdf sdaf asd<param name="Текст">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name="Картинки">https://domen.ru</param> dsfasd fsdaf asd
<param name="Числа">9999</param> sdf as sdf asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end