$re = '/<param name=[^<]+?<\/param>/m';
$str = 'fasfasd fsdaf asdf sdaf asd<param name="Текст">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name="Картинки">https://domen.ru</param> dsfasd fsdaf asd
<param name="Числа">9999</param> sdf as sdf asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);