use strict;
my $str = 'fasfasd fsdaf asdf sdaf asd<param name="Текст">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name="Картинки">https://domen.ru</param> dsfasd fsdaf asd
<param name="Числа">9999</param> sdf as sdf asd';
my $regex = qr/<param name=[^<]+?<\/param>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}