import Foundation
let pattern = #"<param name=[^<]+?<\/param>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fasfasd fsdaf asdf sdaf asd<param name="Текст">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name="Картинки">https://domen.ru</param> dsfasd fsdaf asd
<param name="Числа">9999</param> sdf as sdf asd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)