#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(([€$£]?\s*)?((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?)\s*$|(^(((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?(\s*[$€£]?)\s*$)"
Local $sString = "324242234234234234,324324234223423 €" & @CRLF & _
"234324fsdfsdf3424234" & @CRLF & _
"234.333.333,3 € " & @CRLF & _
"€ 234,3434234" & @CRLF & _
"" & @CRLF & _
"€ 444.444 " & @CRLF & _
"$123.231,1222222 " & @CRLF & _
"" & @CRLF & _
"342342,342"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")