// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(([€$£]?\s*)?((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?)\s*$|(^(((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?(\s*[$€£]?)\s*$)").unwrap();
let string = "324242234234234234,324324234223423 €
234324fsdfsdf3424234
234.333.333,3 €
€ 234,3434234
€ 444.444
$123.231,1222222
342342,342";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}