import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(([€$£]?\\s*)?((\\d{1,3}(\\.\\d{3})+)|\\d+))(,\\d+\\s*)?)\\s*$|(^(((\\d{1,3}(\\.\\d{3})+)|\\d+))(,\\d+\\s*)?(\\s*[$€£]?)\\s*$)";
final String string = "324242234234234234,324324234223423 €\n"
+ "234324fsdfsdf3424234\n"
+ "234.333.333,3 € \n"
+ "€ 234,3434234\n\n"
+ "€ 444.444 \n"
+ "$123.231,1222222 \n\n"
+ "342342,342";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}