import Foundation
let pattern = #"(^(([€$£]?\s*)?((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?)\s*$|(^(((\d{1,3}(\.\d{3})+)|\d+))(,\d+\s*)?(\s*[$€£]?)\s*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
324242234234234234,324324234223423 €
234324fsdfsdf3424234
234.333.333,3 €
€ 234,3434234
€ 444.444
$123.231,1222222
342342,342
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)