import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(youtube|you_other_url_format).*?(?:[\\/]|v=)([a-zA-Z0-9-_]{11})";
        final String string = "http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related\n"
	 + "https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE\n"
	 + "https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE\n"
	 + "https://www.youtube.com/embed/NMKkz9uRXJc";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}