const regex = /(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(youtube|you_other_url_format).*?(?:[\\\/]|v=)([a-zA-Z0-9-_]{11})', 'gmi')
const str = `http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related
https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE
https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE
https://www.youtube.com/embed/NMKkz9uRXJc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}