use strict;
my $str = 'http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related
https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE
https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE
https://www.youtube.com/embed/NMKkz9uRXJc';
my $regex = qr/(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}