import re
regex = re.compile(r"(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related\n"
"https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE\n"
"https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE\n"
"https://www.youtube.com/embed/NMKkz9uRXJc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")