#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)(?:(?:\+|00)33|0)\s*[1-9](?:[\s.-]*\d{2}){4}"
Local $sString = "My phone number is 06 06 06 06 06." & @CRLF & _
"But this one can write +33 606 06 06 06." & @CRLF & _
"My facebook profile is https://www.facebook.com/profile.php?id=100060606060606."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")