using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:(?:\+|00)33|0)\s*[1-9](?:[\s.-]*\d{2}){4}";
string input = @"My phone number is 06 06 06 06 06.
But this one can write +33 606 06 06 06.
My facebook profile is https://www.facebook.com/profile.php?id=100060606060606.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}