use strict;
my $str = 'My phone number is 06 06 06 06 06.
But this one can write +33 606 06 06 06.
My facebook profile is https://www.facebook.com/profile.php?id=100060606060606.';
my $regex = qr/(?<!\S)(?:(?:\+|00)33|0)\s*[1-9](?:[\s.-]*\d{2}){4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}