re = /(?<!\S)(?:(?:\+|00)33|0)\s*[1-9](?:[\s.-]*\d{2}){4}/m
str = 'My phone number is 06 06 06 06 06.
But this one can write +33 606 06 06 06.
My facebook profile is https://www.facebook.com/profile.php?id=100060606060606.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end