const regex = /(?<!\S)(?:(?:\+|00)33|0)\s*[1-9](?:[\s.-]*\d{2}){4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(?:(?:\\+|00)33|0)\\s*[1-9](?:[\\s.-]*\\d{2}){4}', 'gm')
const str = `My phone number is 06 06 06 06 06.
But this one can write +33 606 06 06 06.
My facebook profile is https://www.facebook.com/profile.php?id=100060606060606.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}