#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((?:[0-9]{1,3}\.){3}[0-9]{1,3})"
Local $sString = "IP address: 23.34.5.123" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur " & @CRLF & _
"adipiscing elit, sed do eiusmod tempor " & @CRLF & _
"IP address: 23.34.5.23" & @CRLF & _
"IP address: 23.34.5.124" & @CRLF & _
"incididunt ut labore et dolore magna aliqua. " & @CRLF & _
"Ut enim ad minim veniam, quis nostrud exercitation " & @CRLF & _
"IP address: 23.34.5.3" & @CRLF & _
"ullamco laboris nisi ut aliquip ex ea commodo c" & @CRLF & _
"onsequat. Duis aute irure dolor in reprehenderit i" & @CRLF & _
"n voluptate velit esse cillum dolore eu fugiat nulla " & @CRLF & _
"pariatur. " & @CRLF & _
"IP address: 23.56.5.18Excepteur sint occaecat cupidatat non " & @CRLF & _
"proident, sunt in culpa qui officia deserunt mollit " & @CRLF & _
"anim id est laborumLorem ipsum dolor sit amet, consectetur " & @CRLF & _
"adipiscing elit, sed do eiusmod tempor incididunt " & @CRLF & _
"IP address: 10.34.5.12" & @CRLF & _
"ut labore et dolore magna aliqua. Ut enim ad minim " & @CRLF & _
"veniam, quis nostrud exercitation ullamco laboris " & @CRLF & _
"IP address: 10.4.5.13" & @CRLF & _
"nisi ut aliquip ex ea commodo consequat. " & @CRLF & _
"Duis aute irure dolor in reprehenderit in " & @CRLF & _
"voluptate velit esse cillum dolore eu " & @CRLF & _
"fugiat nulla pariatur. Excepteur sint " & @CRLF & _
"IP address: 2.14.15.213" & @CRLF & _
"occaecat cupidatat non proident, sunt in " & @CRLF & _
"culpa qui officia deserunt mollit anim id est laborum"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")