# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[0-9]{1,3}\.){3}[0-9]{1,3})"
test_str = ("IP address: 23.34.5.123\n"
"Lorem ipsum dolor sit amet, consectetur \n"
"adipiscing elit, sed do eiusmod tempor \n"
"IP address: 23.34.5.23\n"
"IP address: 23.34.5.124\n"
"incididunt ut labore et dolore magna aliqua. \n"
"Ut enim ad minim veniam, quis nostrud exercitation \n"
"IP address: 23.34.5.3\n"
"ullamco laboris nisi ut aliquip ex ea commodo c\n"
"onsequat. Duis aute irure dolor in reprehenderit i\n"
"n voluptate velit esse cillum dolore eu fugiat nulla \n"
"pariatur. \n"
"IP address: 23.56.5.18Excepteur sint occaecat cupidatat non \n"
"proident, sunt in culpa qui officia deserunt mollit \n"
"anim id est laborumLorem ipsum dolor sit amet, consectetur \n"
"adipiscing elit, sed do eiusmod tempor incididunt \n"
"IP address: 10.34.5.12\n"
"ut labore et dolore magna aliqua. Ut enim ad minim \n"
"veniam, quis nostrud exercitation ullamco laboris \n"
"IP address: 10.4.5.13\n"
"nisi ut aliquip ex ea commodo consequat. \n"
"Duis aute irure dolor in reprehenderit in \n"
"voluptate velit esse cillum dolore eu \n"
"fugiat nulla pariatur. Excepteur sint \n"
"IP address: 2.14.15.213\n"
"occaecat cupidatat non proident, sunt in \n"
"culpa qui officia deserunt mollit anim id est laborum")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.