// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((?:[0-9]{1,3}\.){3}[0-9]{1,3})").unwrap();
let string = "IP address: 23.34.5.123
Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor
IP address: 23.34.5.23
IP address: 23.34.5.124
incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation
IP address: 23.34.5.3
ullamco laboris nisi ut aliquip ex ea commodo c
onsequat. Duis aute irure dolor in reprehenderit i
n voluptate velit esse cillum dolore eu fugiat nulla
pariatur.
IP address: 23.56.5.18Excepteur sint occaecat cupidatat non
proident, sunt in culpa qui officia deserunt mollit
anim id est laborumLorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor incididunt
IP address: 10.34.5.12
ut labore et dolore magna aliqua. Ut enim ad minim
veniam, quis nostrud exercitation ullamco laboris
IP address: 10.4.5.13
nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu
fugiat nulla pariatur. Excepteur sint
IP address: 2.14.15.213
occaecat cupidatat non proident, sunt in
culpa qui officia deserunt mollit anim id est laborum";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}