import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[0-9]{1,3}\\.){3}[0-9]{1,3})";
final String string = "IP address: 23.34.5.123\n"
+ "Lorem ipsum dolor sit amet, consectetur \n"
+ "adipiscing elit, sed do eiusmod tempor \n"
+ "IP address: 23.34.5.23\n"
+ "IP address: 23.34.5.124\n"
+ "incididunt ut labore et dolore magna aliqua. \n"
+ "Ut enim ad minim veniam, quis nostrud exercitation \n"
+ "IP address: 23.34.5.3\n"
+ "ullamco laboris nisi ut aliquip ex ea commodo c\n"
+ "onsequat. Duis aute irure dolor in reprehenderit i\n"
+ "n voluptate velit esse cillum dolore eu fugiat nulla \n"
+ "pariatur. \n"
+ "IP address: 23.56.5.18Excepteur sint occaecat cupidatat non \n"
+ "proident, sunt in culpa qui officia deserunt mollit \n"
+ "anim id est laborumLorem ipsum dolor sit amet, consectetur \n"
+ "adipiscing elit, sed do eiusmod tempor incididunt \n"
+ "IP address: 10.34.5.12\n"
+ "ut labore et dolore magna aliqua. Ut enim ad minim \n"
+ "veniam, quis nostrud exercitation ullamco laboris \n"
+ "IP address: 10.4.5.13\n"
+ "nisi ut aliquip ex ea commodo consequat. \n"
+ "Duis aute irure dolor in reprehenderit in \n"
+ "voluptate velit esse cillum dolore eu \n"
+ "fugiat nulla pariatur. Excepteur sint \n"
+ "IP address: 2.14.15.213\n"
+ "occaecat cupidatat non proident, sunt in \n"
+ "culpa qui officia deserunt mollit anim id est laborum";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}