import Foundation
let pattern = #"((?:[0-9]{1,3}\.){3}[0-9]{1,3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
IP address: 23.34.5.123
Lorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor
IP address: 23.34.5.23
IP address: 23.34.5.124
incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation
IP address: 23.34.5.3
ullamco laboris nisi ut aliquip ex ea commodo c
onsequat. Duis aute irure dolor in reprehenderit i
n voluptate velit esse cillum dolore eu fugiat nulla
pariatur.
IP address: 23.56.5.18Excepteur sint occaecat cupidatat non
proident, sunt in culpa qui officia deserunt mollit
anim id est laborumLorem ipsum dolor sit amet, consectetur
adipiscing elit, sed do eiusmod tempor incididunt
IP address: 10.34.5.12
ut labore et dolore magna aliqua. Ut enim ad minim
veniam, quis nostrud exercitation ullamco laboris
IP address: 10.4.5.13
nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu
fugiat nulla pariatur. Excepteur sint
IP address: 2.14.15.213
occaecat cupidatat non proident, sunt in
culpa qui officia deserunt mollit anim id est laborum
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)