# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[()\h]+/-/g;t' <<< "+91 (333) 444-5678
+1(333) 456-7890"