// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[()\h]+").unwrap();
let string = "+91 (333) 444-5678
+1(333) 456-7890";
let substitution = "-";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}