#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[()\h]+"
Local $sString = "+91 (333) 444-5678" & @CRLF & _
"+1(333) 456-7890"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)